Lenguaje C Ayuda

Tema en 'Foro Libre' iniciado por irwing, 22 Jul 2009.

  1. irw

    irwing
    Expand Collapse
    Recluta

    Mensajes:
    6
    Me Gusta recibidos:
    0
    Bueno Me mandaron unos cuantos ejercicios de practica, pero estos 3 son los que no estoy seguro de si hice bien el código... los hice pero no se si son así quisiera que me ayudaran un poco con la lógica ver si estoy bien...

    1)realize un programa dado 20 numeros enteros calcule la suma de los numeros impares y el promedio de los numeros pares

    2) realize un programa que muestre regresivamente del 1000 al 1 , muestre el conteo y realize la sumatoria de todo los numeros que sean multiplo de 5...

    el otro no lo consiguo quisiera su ayuda gracias
     
  2. Apo

    Apokryphos
    Expand Collapse
    Recluta

    Mensajes:
    14
    Me Gusta recibidos:
    0
    1) bueno como especificas donde estan almacenados los numeros; voy a suponer que son una entrada directa
    // n es la variable donde se almacena temporalmente los 20 nuemros; claro //uno por uno

    para i=o hasta i <20 entonces
    si (n mod 2 = 0) entonces // se compara si es par o impar
    x = n; //acumulador de pares
    sino
    z = z + 1; //contador de numeros impares para promediar
    y = n; //acumulador de impares
    fin si;
    fin para;

    imprimir("la suma de los impares es:" y);
    imprimir("el promedio de los pares es:"x/z);

    2) para este pudes usar cualquier sentencia de repeticion en este caso usare un mientras para variar la cosa jeje xD

    entero i = 1000, acum = 0;
    mientras (i <> 0) entonces // el distinto varia segun el lenguaje !=
    imprimir("numero:"i);
    si (i mod 5 = 0) entonces
    acum = acum + i;
    fin si
    i = i-1;
    fin mientras;
    imprimir ("La suma de los multiplos de 5 es:"acum+5);
    // se le suman 5 porque nos falta preguntar si 5 es multiplo de 5

    eso es todo; para la proxima si me das mayores datos y el lenguaje de programacion que necesitas te ayudo

    si quieres me escribes a mi correo y msm es josexo010@gmail.com porque por gamerzlove paso de ves en cuando.
     
  3. irw

    irwing
    Expand Collapse
    Recluta

    Mensajes:
    6
    Me Gusta recibidos:
    0
    gracias man si nesecito otra ayuda te escribo a tu correo
     
  4. Apo

    Apokryphos
    Expand Collapse
    Recluta

    Mensajes:
    14
    Me Gusta recibidos:
    0
    ok simpre dispuesto a ayudar
     
  5. Dr. House

    Dr. House
    Expand Collapse
    Capitán

    Mensajes:
    645
    Me Gusta recibidos:
    3
    Ezo creo que es DOS ..

    Zi necesitas ayuda con C++ ...

    o algun otro tipo de lenguaje ..
    Agregame : eduardo5734@hotmail.com

    X Apokryphos ... agregame quiero hablar contigo xP ..
    tengo un trabajo para ti -.- !
     
  6. Apo

    Apokryphos
    Expand Collapse
    Recluta

    Mensajes:
    14
    Me Gusta recibidos:
    0
    Listo compadre agregado
     
  7. nid

    nidokinggg
    Expand Collapse
    Cabo

    Mensajes:
    124
    Me Gusta recibidos:
    0
    el primer ejercicio lo resolviste de una manera poco eficiente, antes que nada te puedo plantear 2 tipos de soluciones para el primer ejercicio, una con arreglos u otra sin arreglos(la mas ineficiente pero igualmente de eficaz) cualquier cosa si aun necesitas las respuestas escribe aqui en el foro y te ayudo... un consejo, repasa tus clases ahi esta la respuesta -.-. pero s qieras ayuda pide nomas algunos no somos tan ratas (aveces xD)
     

Compartir esta página